using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[012356789][023456789][012345789]\d{7}\b";
string input = @"Match:
1234567890
9873245897
No match
4162345111
4162387222
897345890722 longer than 10";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}