$re = '/\b[012356789][023456789][012345789]\d{7}\b/m';
$str = 'Match:
1234567890
9873245897
No match
4162345111
4162387222
897345890722 longer than 10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);