#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(Em\s)?\d{1,2}\sde\s\w+\sde\s\d{4}\s\d{1,2}:\d{1,2}([^@]+@\w+\.\w+\.\w+|,\s\sescreveu\:)?"
Local $sString = "Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat." & @CRLF & _
"" & @CRLF & _
"5 de Abril de 2018 10:50, atendimento@teste.com.br (mailto:atendimento@teste.com.br) escreveu:teste" & @CRLF & _
"" & @CRLF & _
"Em 5 de Abril de 2018 10:30, atendimento@teste.com.br (mailto:atendimento@teste.com.br) escreveu:resposta atendimento" & @CRLF & _
"" & @CRLF & _
"-----------------------------------------------------------" & @CRLF & _
"" & @CRLF & _
"Olá, como vai?" & @CRLF & _
"" & @CRLF & _
"10 de abril de 2018 09:49" & @CRLF & _
"" & @CRLF & _
"10 de abril de 2018 09:49, escreveu:" & @CRLF & _
"" & @CRLF & _
"Em 10 de abril de 2018 09:49" & @CRLF & _
"" & @CRLF & _
"Em 10 de abril de 2018 09:49, escreveu:" & @CRLF & _
"" & @CRLF & _
"> Resposta atendimento" & @CRLF & _
">" & @CRLF & _
">" & @CRLF & _
"> 10 de Abril de 2018 09:48, "erick zanetti" > escreveu:" & @CRLF & _
">" & @CRLF & _
">" & @CRLF & _
"> Olá, erick," & @CRLF & _
"> A data de entrega do seu trabalho Lista Vetores" & @CRLF & _
"> é" & @CRLF & _
"> amanhã. Você deseja entregá-lo?" & @CRLF & _
">" & @CRLF & _
">" & @CRLF & _
"> Lista Vetores" & @CRLF & _
"> Prazo: 7 de abr" & @CRLF & _
"> ABRIR" & @CRLF & _
">" & @CRLF & _
"> Se você não quiser receber e-mails do Sala de aula, cancele sua inscrição" & @CRLF & _
"> ." & @CRLF & _
">" & @CRLF & _
">" & @CRLF & _
">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")