package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(Em\s)?\d{1,2}\sde\s\w+\sde\s\d{4}\s\d{1,2}:\d{1,2}([^@]+@\w+\.\w+\.\w+|,\s\sescreveu\:)?`)
var str = `Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.
5 de Abril de 2018 10:50, atendimento@teste.com.br (mailto:atendimento@teste.com.br) escreveu:teste
Em 5 de Abril de 2018 10:30, atendimento@teste.com.br (mailto:atendimento@teste.com.br) escreveu:resposta atendimento
-----------------------------------------------------------
Olá, como vai?
10 de abril de 2018 09:49
10 de abril de 2018 09:49, escreveu:
Em 10 de abril de 2018 09:49
Em 10 de abril de 2018 09:49, escreveu:
> Resposta atendimento
>
>
> 10 de Abril de 2018 09:48, "erick zanetti" > escreveu:
>
>
> Olá, erick,
> A data de entrega do seu trabalho Lista Vetores
> é
> amanhã. Você deseja entregá-lo?
>
>
> Lista Vetores
> Prazo: 7 de abr
> ABRIR
>
> Se você não quiser receber e-mails do Sala de aula, cancele sua inscrição
> .
>
>
>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}