package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){[^}]+}`)
var str = `some_var = {
'foo': 'bar',
'list_foo': ['bar1', 'bar2'],
}
other_var = [
{
'foo1': 'bar1',
'foo2': True
},
{
'foo_list1': ['bar3', 'bar4'],
'foo2': 'bar2'
},
]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}