$re = '/{[^}]+}/m';
$str = 'some_var = {
\'foo\': \'bar\',
\'list_foo\': [\'bar1\', \'bar2\'],
}
other_var = [
{
\'foo1\': \'bar1\',
\'foo2\': True
},
{
\'foo_list1\': [\'bar3\', \'bar4\'],
\'foo2\': \'bar2\'
},
]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);