#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(*CRLF)CONCLUSION:\sImpression\s\s"
Local $sString = "Impression CONCLUSION:" & @CRLF & _
"Impression" & @CRLF & _
"" & @CRLF & _
"Impression CONCLUSION:" & @CRLF & _
"Impression SomeData" & @CRLF & _
"" & @CRLF & _
"Impression CONCLUSION:" & @CRLF & _
"Impression SomeOtherData" & @CRLF & _
"" & @CRLF & _
"Impression CONCLUSION:" & @CRLF & _
"Impression" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")