re = /(*CRLF)CONCLUSION:\sImpression\s\s/m
str = 'Impression CONCLUSION:
Impression
Impression CONCLUSION:
Impression SomeData
Impression CONCLUSION:
Impression SomeOtherData
Impression CONCLUSION:
Impression
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end