re = /(http(s)?:\/\/www.)?((flipkart(?:.com)+([^\s\.]+[^\s]*)+[^,.\s]))/m
str = 'https://www.flipkart.com/sansui-pro-view-102cm-40-inch-full-hd-led-tv-2019/p/itmfg2fyuschpzha?pid=TVSFG2FYGQG8MCWK&affid=extinr&affExtParam1=mbu511967417_34289009_65'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end