package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:\w|[_\-.])+?\[(?:\w|[_\-.])+\]|^\[\s*(?:\w|[_\-.])+\s*\]`)
var str = `foo[ bar]
foo[bar ]
foo[ bar ]
[ bar]
[bar ]
[ bar ]
foo[bar]
test
Lorem ipsum dolor sit amet
if (a === b) {
b = c;
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}