$re = '/^(?:\w|[_\-.])+?\[(?:\w|[_\-.])+\]|^\[\s*(?:\w|[_\-.])+\s*\]/mi';
$str = 'foo[ bar]
foo[bar ]
foo[ bar ]
[ bar]
[bar ]
[ bar ]
foo[bar]
test
Lorem ipsum dolor sit amet
if (a === b) {
b = c;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);