$re = '/.*={{(?>(\.)|(?>\w+)+)}}/';
$str = 'some.blah.key={{blah.woot.wiz}}
some.another.foo.key={{foo.bar.qix.name}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);