re = /.*={{(?>(\.)|(?>\w+)+)}}/
str = 'some.blah.key={{blah.woot.wiz}}
some.another.foo.key={{foo.bar.qix.name}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end