#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b((?=[a-z0-9-]{1,63}\.)(xn--)?[a-z0-9]+(-[a-z0-9]+)*\.)+[a-z]{2,63}\b"
Local $sString = "example.com" & @CRLF & _
"sub.eample.com" & @CRLF & _
"sub-dash.example.com" & @CRLF & _
"sub.sub2-dash.example.com" & @CRLF & _
"sub.example-dash.com" & @CRLF & _
"sub123.example.com" & @CRLF & _
"sub.sub123.example.com" & @CRLF & _
"www.thisislongerthansixtyonecharacterswhichisnotallowedbythestandards.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")