$re = '/\b((?=[a-z0-9-]{1,63}\.)(xn--)?[a-z0-9]+(-[a-z0-9]+)*\.)+[a-z]{2,63}\b/m';
$str = 'example.com
sub.eample.com
sub-dash.example.com
sub.sub2-dash.example.com
sub.example-dash.com
sub123.example.com
sub.sub123.example.com
www.thisislongerthansixtyonecharacterswhichisnotallowedbythestandards.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);