package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)\{{2}.*?\}{2}`)
var str = `{{test}} {test1} {{test2}} {test5} {{test3}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}