$re = '/\{{2}.*?\}{2}/is';
$str = '{{test}} {test1} {{test2}} {test5} {{test3}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);