import re
regex = re.compile(r"les-programmes\/[^\/]+\/.*$")
test_str = ("/les-programmes/mon-premier-festival-2017\n"
"/les-programmes/les-incassables\n"
"/les-programmes/100-doc-colombie/nuestra-voz-de-tierra-memoria-y-futuro\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")