#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(upload\/.*?)[0-9]+$"
Local $sString = "upload/.bes/.ur/13" & @CRLF & _
"upload/.tables/.u23ser/15" & @CRLF & _
"upload/.tles2/.uer/11" & @CRLF & _
"upload/1.tales/.user2/01"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")