re = /^(upload\/.*?)[0-9]+$/m
str = 'upload/.bes/.ur/13
upload/.tables/.u23ser/15
upload/.tles2/.uer/11
upload/1.tales/.user2/01'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end