#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=(ch-name">)|(?<=ch-time">)|(?<=ch-type">)|(?<=ch-text">))[\s\S]*?(?=<\/)"
Local $sString = "<ul id="channelList">" & @CRLF & _
" <li class="odd">" & @CRLF & _
" <span class="ch-type">Canlı</span><!-- 1-->" & @CRLF & _
" <span class="ch-time">06:30</span><!-- 2-->" & @CRLF & _
" <div class="ch-desc">" & @CRLF & _
" <span class="ch-name">NBA TV</span><!-- 3-->" & @CRLF & _
" <span class="ch-text">Sacramento Kings - N.Orleans Pelicans (Basketbol)</span><!-- 4-->" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="even">" & @CRLF & _
" <span class="ch-type">Canlı</span>" & @CRLF & _
" <span class="ch-time">07:45</span>" & @CRLF & _
" <div class="ch-desc">" & @CRLF & _
" <span class="ch-name">TRT Spor</span>" & @CRLF & _
" <span class="ch-text">İlk Baskı (Futbol)</span>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="odd">" & @CRLF & _
" <span class="ch-type">Canlı</span>" & @CRLF & _
" <span class="ch-time">11:00</span>" & @CRLF & _
" <div class="ch-desc">" & @CRLF & _
" <span class="ch-name">TRT Spor</span>" & @CRLF & _
" <span class="ch-text">Spor Manşet (Futbol)</span>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="even">" & @CRLF & _
" <span class="ch-type">Canlı</span>" & @CRLF & _
" <span class="ch-time">11:05</span>" & @CRLF & _
" <div class="ch-desc">" & @CRLF & _
" <span class="ch-name">NTV Spor</span>" & @CRLF & _
" <span class="ch-text">Spor Servisi (Futbol)</span>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="odd">" & @CRLF & _
" <span class="ch-type">Canlı</span>" & @CRLF & _
" <span class="ch-time">12:15</span>" & @CRLF & _
" <div class="ch-desc">" & @CRLF & _
" <span class="ch-name">TRT Spor</span>" & @CRLF & _
" <span class="ch-text">Set-Maç-Smaç (Voleybol)</span>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="even">" & @CRLF & _
" <span class="ch-type">Canlı</span>" & @CRLF & _
" <span class="ch-time">13:00</span>" & @CRLF & _
" <div class="ch-desc">" & @CRLF & _
" <span class="ch-name">Kanal 58</span>" & @CRLF & _
" <span class="ch-text">Sivas Bld. - Pendikspor (Futbol)</span>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="odd">" & @CRLF & _
" <span class="ch-type">Canlı</span>" & @CRLF & _
" <span class="ch-time">13:00</span>" & @CRLF & _
" <div class="ch-desc">" & @CRLF & _
" <span class="ch-name">Kardelen TV</span>" & @CRLF & _
" <span class="ch-text">BB Erzurumspor - Zonguldak (Futbol)</span>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="even">" & @CRLF & _
" <span class="ch-type">Canlı</span>" & @CRLF & _
" <span class="ch-time">14:00</span>" & @CRLF & _
" <div class="ch-desc">" & @CRLF & _
" <span class="ch-name">Lig Tv</span>" & @CRLF & _
" <span class="ch-text">Futbol Gündemi (Futbol)</span>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="odd">" & @CRLF & _
" <span class="ch-type">Canlı</span>" & @CRLF & _
" <span class="ch-time">14:00</span>" & @CRLF & _
" <div class="ch-desc">" & @CRLF & _
" <span class="ch-name">NTV Spor</span>" & @CRLF & _
" <span class="ch-text">Spor Aktüel (Futbol)</span>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="even">" & @CRLF & _
" <span class="ch-type">Canlı</span>" & @CRLF & _
" <span class="ch-time">20:00</span>" & @CRLF & _
" <div class="ch-desc">" & @CRLF & _
" <span class="ch-name">Tivibu Spor</span>" & @CRLF & _
" <span class="ch-text">Doğru Taktik (Futbol)</span>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="odd">" & @CRLF & _
" <span class="ch-type">Canlı</span>" & @CRLF & _
" <span class="ch-time">20:00</span>" & @CRLF & _
" <div class="ch-desc">" & @CRLF & _
" <span class="ch-name">NTV Spor</span>" & @CRLF & _
" <span class="ch-text">Kırmızı Çizgi (Futbol)</span>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="even">" & @CRLF & _
" <span class="ch-type">Canlı</span>" & @CRLF & _
" <span class="ch-time">20:00</span>" & @CRLF & _
" <div class="ch-desc">" & @CRLF & _
" <span class="ch-name">A Spor</span>" & @CRLF & _
" <span class="ch-text">Beşiktaş SJ - Zielona Gora (Basketbol)</span>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="odd">" & @CRLF & _
" <span class="ch-type">Canlı</span>" & @CRLF & _
" <span class="ch-time">20:30</span>" & @CRLF & _
" <div class="ch-desc">" & @CRLF & _
" <span class="ch-name">Eurosport 2</span>" & @CRLF & _
" <span class="ch-text">Lokomotiv Kuban - Valencia Basket (Basketbol)</span>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="even">" & @CRLF & _
" <span class="ch-type">Canlı</span>" & @CRLF & _
" <span class="ch-time">21:00</span>" & @CRLF & _
" <div class="ch-desc">" & @CRLF & _
" <span class="ch-name">TRT Spor</span>" & @CRLF & _
" <span class="ch-text">Futbol Keyfi (Futbol)</span>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="odd">" & @CRLF & _
" <span class="ch-type">Canlı</span>" & @CRLF & _
" <span class="ch-time">21:00</span>" & @CRLF & _
" <div class="ch-desc">" & @CRLF & _
" <span class="ch-name">Tivibu Spor</span>" & @CRLF & _
" <span class="ch-text">Ters Köşe (Futbol)</span>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="even">" & @CRLF & _
" <span class="ch-type">Canlı</span>" & @CRLF & _
" <span class="ch-time">22:00</span>" & @CRLF & _
" <div class="ch-desc">" & @CRLF & _
" <span class="ch-name">TRT Spor</span>" & @CRLF & _
" <span class="ch-text">Devler Sahnesi (Futbol)</span>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="odd">" & @CRLF & _
" <span class="ch-type">Canlı</span>" & @CRLF & _
" <span class="ch-time">22:00</span>" & @CRLF & _
" <div class="ch-desc">" & @CRLF & _
" <span class="ch-name">Smartspor 2</span>" & @CRLF & _
" <span class="ch-text">Aris - Banvit (Basketbol)</span>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="even">" & @CRLF & _
" <span class="ch-type">Canlı</span>" & @CRLF & _
" <span class="ch-time">22:15</span>" & @CRLF & _
" <div class="ch-desc">" & @CRLF & _
" <span class="ch-name">Eurosport 2</span>" & @CRLF & _
" <span class="ch-text">Bilbao Basket - Khimki Moskova (Basketbol)</span>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="odd">" & @CRLF & _
" <span class="ch-type">Canlı</span>" & @CRLF & _
" <span class="ch-time">23:00</span>" & @CRLF & _
" <div class="ch-desc">" & @CRLF & _
" <span class="ch-name">NTV Spor</span>" & @CRLF & _
" <span class="ch-text">Spor Gecesi (Futbol)</span>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="even">" & @CRLF & _
" <span class="ch-type">Canlı</span>" & @CRLF & _
" <span class="ch-time">23:30</span>" & @CRLF & _
" <div class="ch-desc">" & @CRLF & _
" <span class="ch-name">TRT Spor</span>" & @CRLF & _
" <span class="ch-text">Spor Gecesi (Futbol)</span>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="odd">" & @CRLF & _
" <span class="ch-type">Canlı</span>" & @CRLF & _
" <span class="ch-time">03:00</span>" & @CRLF & _
" <div class="ch-desc">" & @CRLF & _
" <span class="ch-name">NBA TV</span>" & @CRLF & _
" <span class="ch-text">Washington Wizards - Boston Celtics (Basketbol)</span>" & @CRLF & _
" </div>" & @CRLF & _
" </li></ul>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")