# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^.*:.*):(.*$)"
test_str = ("52152525121512@gmail.com:161361361:1251136136\n"
"532353472626326@gmail.com:2361251251225:-\n"
"126125252155@gmail.com:215125151251252:135263623,13631535315\n\n")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.