const regex = /\w+\s*(\((?:[^()]++|(?-1))*\))\s*=\s*\w+\s*({(?:[^{}]++|(?-1))*})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+\\s*(\\((?:[^()]++|(?-1))*\\))\\s*=\\s*\\w+\\s*({(?:[^{}]++|(?-1))*})', 'gm')
const str = `foo(f1, f2()) = bar { b1, b2 {}}
//match all of this
foo(f3)
// dont match this
bar{b3}
// dont match this`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}