$re = '/\w+\s*(\((?:[^()]++|(?-1))*\))\s*=\s*\w+\s*({(?:[^{}]++|(?-1))*})/m';
$str = 'foo(f1, f2()) = bar { b1, b2 {}}
//match all of this
foo(f3)
// dont match this
bar{b3}
// dont match this';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);