$re = '/(",(?=(?:[^\"]*\"[^\"]*\")*[^\"]*$)", -1)/';
$str = 'DUS-FRONTARENA@20230904,SA_GREEKS_CRR2_ECB,SA_GREEKS_CRR2_ECB_USD,1100accf-4b74-475a-a9bd-9ccc6c434030,CRFRTBEAD,USD,5274107.002018,7000000000435111897,OFFICIAL_spot_0,NULL,NULL,NULL,NULL,NULL,TERNA - RETE ELETTRICA NAZIONALE SOCIETA\' PER AZI,N,20230905104510489,NULL,USD,7000000000435111897,NULL
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);