import Foundation
let pattern = #"(",(?=(?:[^\"]*\"[^\"]*\")*[^\"]*$)", -1)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
DUS-FRONTARENA@20230904,SA_GREEKS_CRR2_ECB,SA_GREEKS_CRR2_ECB_USD,1100accf-4b74-475a-a9bd-9ccc6c434030,CRFRTBEAD,USD,5274107.002018,7000000000435111897,OFFICIAL_spot_0,NULL,NULL,NULL,NULL,NULL,TERNA - RETE ELETTRICA NAZIONALE SOCIETA' PER AZI,N,20230905104510489,NULL,USD,7000000000435111897,NULL
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}