package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(00355\) \d{2}-\d{3}-\d{4}`)
var str = `(00355) 22-333-4444`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}