$re = '/\s*,(?=(?:[^\']*\'[^\']*\')*[^\']*$)\s*/m';
$str = '\'Hello world\',dude, Somethings, never, turn and go, bye
\'Hello world\',dude, \'Somethings, never, turn and go\', bye';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);