$re = '/((?:\d{1,3}\.){3}\d{1,3})/';
$str = '192.168.1.1
88.88.88.88
255.255.255.255
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);