re = /((?:\d{1,3}\.){3}\d{1,3})/
str = '192.168.1.1
88.88.88.88
255.255.255.255
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end