package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?(DEFINE)
(?<ips>[^()]+)
(?<incoming>Incoming\ Interface \ List)
(?<outgoing>Outgoing\ Interface \ List)
(?<end>^$|\Z)
)
^\((?P<ip>(?&ips))\)
(?:(?!(?&incoming))[\s\S]+?)
(?&incoming)[\r\n]
(?P<in>(?!(?&outgoing))[\s\S]+?)
(?&outgoing)[\r\n]
(?P<out>(?!^$)[\s\S]+?)
(?&end)`)
var str = `(192.168.1.1,232.0.6.8) RPF nbr: 55.44.23.1 Flags: RPF
Up: 4w1d
Incoming Interface List
TenGigE0/0/0/1 Flags: A, Up: 4w1d
Outgoing Interface List
TenGigE0/0/0/10 Flags: A, Up: 4w1d
(192.168.55.3,232.0.10.69) RPF nbr: 66.76.44.130 Flags: RPF
Up: 4w1d
Incoming Interface List
TenGigE0/0/0/0 Flags: A, Up: 4w1d
TenGigE0/1/0/0 Flags: A, Up: 4w1d
TenGigE0/2/0/0 Flags: A, Up: 4w1d
Outgoing Interface List
TenGigE0/0/0/10 Flags: A, Up: 4w1d
TenGigE0/3/0/0 Flags: A, Up: 4w1d
TenGigE0/4/0/0 Flags: A, Up: 4w1d`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}