import re
regex = re.compile(r"""
(?(DEFINE)
(?<ips>[^()]+)
(?<incoming>Incoming\ Interface \ List)
(?<outgoing>Outgoing\ Interface \ List)
(?<end>^$|\Z)
)
^\((?P<ip>(?&ips))\)
(?:(?!(?&incoming))[\s\S]+?)
(?&incoming)[\r\n]
(?P<in>(?!(?&outgoing))[\s\S]+?)
(?&outgoing)[\r\n]
(?P<out>(?!^$)[\s\S]+?)
(?&end)
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("(192.168.1.1,232.0.6.8) RPF nbr: 55.44.23.1 Flags: RPF\n"
" Up: 4w1d\n"
" Incoming Interface List\n"
" TenGigE0/0/0/1 Flags: A, Up: 4w1d\n"
" Outgoing Interface List\n"
" TenGigE0/0/0/10 Flags: A, Up: 4w1d\n\n"
"(192.168.55.3,232.0.10.69) RPF nbr: 66.76.44.130 Flags: RPF\n"
" Up: 4w1d\n"
" Incoming Interface List\n"
" TenGigE0/0/0/0 Flags: A, Up: 4w1d\n"
" TenGigE0/1/0/0 Flags: A, Up: 4w1d\n"
" TenGigE0/2/0/0 Flags: A, Up: 4w1d\n"
" Outgoing Interface List\n"
" TenGigE0/0/0/10 Flags: A, Up: 4w1d\n"
" TenGigE0/3/0/0 Flags: A, Up: 4w1d\n"
" TenGigE0/4/0/0 Flags: A, Up: 4w1d")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")