import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:in|and|is)\\s+((?:.(?!\\b(?:in|and|is)\\b))*HomeStay(?:.(?!\\b(?:in|and|is)\\b))*)";
final String string = "Hello, tonight I'm in the town of Trenton in Hotel HomeStay [123] in New Jersey and I will be staying in Hotel HomeStay [123] and I have no money. Actually, I'm wealthier than this guy outside, I will be staying in Hotel HomeStay [123] and I have tons of money. in Hotelin HomeStay [123in]. and never gonna give you up, never gonna make you cry.\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}