$re = '/\b(?:in|and|is)\s+((?:.(?!\b(?:in|and|is)\b))*HomeStay(?:.(?!\b(?:in|and|is)\b))*)/m';
$str = 'Hello, tonight I\'m in the town of Trenton in Hotel HomeStay [123] in New Jersey and I will be staying in Hotel HomeStay [123] and I have no money. Actually, I\'m wealthier than this guy outside, I will be staying in Hotel HomeStay [123] and I have tons of money. in Hotelin HomeStay [123in]. and never gonna give you up, never gonna make you cry.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);