package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([^-]+)[^\(]+(\([^\)]+\))`)
var str = `Mais de - valor: R$3.21 - Tipo: (+05)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}