use strict;
my $str = '<div
id="Content">
<p>1</p>
<h2>1</h2>
<h2>2</h2>
</div>';
my $regex = qr/(<.*?>)/p;
my $subst = '<span>$1</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";