import Foundation
let pattern = #"(<.*?>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div
id="Content">
<p>1</p>
<h2>1</h2>
<h2>2</h2>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span>$1</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)