const regex = /\b(\d{3})(\d{3})(\d{4})([\Q-()[]{}':;""/\,.?!`n `t\E])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d{3})(\\d{3})(\\d{4})([\\Q-()[]{}\':;""\/\\,.?!`n `t\\E])', '')
const str = ` 1234567890
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}