$re = '/\b(\d{3})(\d{3})(\d{4})([\Q-()[]{}\':;""/\,.?!`n `t\E])/';
$str = ' 1234567890
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);