$re = '/(?<=[?&]id=)[^&\n]+/';
$str = 'https://play.google.com/store/apps/details?id=com.opera.mini.native
https://play.google.com/store/apps/details?id=com.opera.mini.native&referrer=xxxx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);