re = /(?<=[?&]id=)[^&\n]+/
str = 'https://play.google.com/store/apps/details?id=com.opera.mini.native
https://play.google.com/store/apps/details?id=com.opera.mini.native&referrer=xxxx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end