use strict;
my $str = '1234567890';
my $regex = qr/(?<=\d)(?=(\d\d\d)+\b)/mp;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";