$re = '/(?<=\d)(?=(\d\d\d)+\b)/m';
$str = '1234567890';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;