re = /(?<=<BASE)\s+href="(.*)(?=")/
str = '<BASE href="http://whatreallyhappened.com/">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end