$re = '/[\₱]{0,1}[0-9]*[.]{0,1}[0-9]{0,2}/m';
$str = '100.0
100.00
₱100.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);