import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "from:\\s*([0-9\\-\\s:]+),\\s*to:([0-9\\-\\s:]+),\\s*downtime:\\s*([0-9\\shms]+)";
final String string = "AB\\r\\n\\r\\n--_=_swift_v4_13613629825124c026192e8_=_\\r\\nContent-Type: multipart/related;\\r\\n oundary=\"_=_swift_v4_13613629825124c02620826_=_\"\\r\\n\\r\\n--_ =_swift_v4_13613629825124c02620826_=_\\r\\n\n"
+ "From: 2013-01-11 04:26:07, To: 2013-01-11 05:56:08, Downtime: 1h 30m 01s\\r\\n\\r\\n\n"
+ "some more text here From: 2013-01-29 04:51:07, To: 2013-01-29 05:41:07, Downtime: 0h 50m 00s\\r\\n\\r\\n\\r\\n\\r\\n\\r\\n This is a scheduled report from If you wish to no longer receive t=\\r\\nhis report you can unsubscribe by logging in to and u=\\r\\npdate your email report settings.\\r\\nCopyright: 2013 \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}