$re = '/from:\s*([0-9\-\s:]+),\s*to:([0-9\-\s:]+),\s*downtime:\s*([0-9\shms]+)/mi';
$str = 'AB\\r\\n\\r\\n--_=_swift_v4_13613629825124c026192e8_=_\\r\\nContent-Type: multipart/related;\\r\\n oundary="_=_swift_v4_13613629825124c02620826_=_"\\r\\n\\r\\n--_ =_swift_v4_13613629825124c02620826_=_\\r\\n
From: 2013-01-11 04:26:07, To: 2013-01-11 05:56:08, Downtime: 1h 30m 01s\\r\\n\\r\\n
some more text here From: 2013-01-29 04:51:07, To: 2013-01-29 05:41:07, Downtime: 0h 50m 00s\\r\\n\\r\\n\\r\\n\\r\\n\\r\\n This is a scheduled report from If you wish to no longer receive t=\\r\\nhis report you can unsubscribe by logging in to and u=\\r\\npdate your email report settings.\\r\\nCopyright: 2013
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);