using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(%({)?([A-Za-z0-9]+)(?(2)}))";
string input = @"asdfasdfds%{ASDF}sdfasdf %asdsa
Match either %MACRO or %{MACRO}, but not ${MACRO nor %MACRO}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}