#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\{\w+:array,\w+,\w+,([^}]+?),([^}]+?)\}|\{\w+:(int|float),([^}]+?),([^}]+?)\}"
Local $sString = "{n:int,1,50}" & @CRLF & _
"{a:array,n,int,1,1e8}" & @CRLF & _
"{b:array,n,int,1,1e8}" & @CRLF & _
"" & @CRLF & _
"{n:int,1,1e5} {k:int,0,min(n-1,10)}" & @CRLF & _
"{p:array,n,int,1,1e9}" & @CRLF & _
"{c:array,n,int,0,1e9}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")