const regex = new RegExp('\\{\\w+:array,\\w+,\\w+,([^}]+?),([^}]+?)\\}|\\{\\w+:(int|float),([^}]+?),([^}]+?)\\}', 'gm')
const str = `{n:int,1,50}
{a:array,n,int,1,1e8}
{b:array,n,int,1,1e8}
{n:int,1,1e5} {k:int,0,min(n-1,10)}
{p:array,n,int,1,1e9}
{c:array,n,int,0,1e9}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}